Cant connect to most private trackers

Hi. first of all thanks for your great tool. imho its the best terminal client out there. but i got a serious problem: I cant dl from most private trackers. the torrent is starting ok, but shortly after BTqueue shouts FAILURE X the info is working, so i think btq aint passing my passkey correctly. it doesnt work if the announce url looks like this: http://torrents.org/announce.php?passkey=XXX but, it works on tl http://tracker.torrentleech.org:2710/a/XXX/announce hope, you fix it soon

oops!

Ahh. It seems both BitTornado and BitTorrent assuming that there might not have any "?" in announce url. I will fix it today.

Is this fixed already? I

Is this fixed already? I still get the following error: Last Error: Aborting the torrent as it was rejected by the tracker while not connected to any peers. Message from the tracker: Invalid passkey! Re-download the .torrent from http://www.abcdefg.net The announce URL: http://tracker.abcdefg.net/announce.php?passkey=6e7b313d17810b7309cbb2fd23414dc2 The version of BTQueue I use is: Q-0.1.0 433 (BitQueue) Kind regards Bielie

should be fixed

This problem should be fixed since Q-0.1.0 411. Umm. I will check it again. Index: BitTorrent/Rerequester.py =================================================================== --- BitTorrent/Rerequester.py (revision 280) +++ BitTorrent/Rerequester.py (working copy) @@ -62,9 +62,18 @@ self.tracker_num_seeds = None def _makeurl(self, peerid, port): - return ('%s?info_hash=%s&peer_id=%s&port=%s&key=%s' % - (self.baseurl, quote(self.infohash), quote(peerid), str(port), + url = ('info_hash=%s&peer_id=%s&port=%s&key=%s' % + (quote(self.infohash), quote(peerid), str(port), b2a_hex(''.join([chr(randrange(256)) for i in xrange(4)])))) + try: + url += '&local_ip=%s' % quote(gethostbyname(gethostname())) + except: + pass + if self.baseurl.find('?') >= 0: + c = '&' + else: + c = '?' + return '%s%s%s' % (self.baseurl,c,url) def change_port(self, peerid, port): self.wanted_peerid = peerid

Similar problem

I have a problem with the latest build (BTQueue 0.1.1 build 451 on WinXP) on my own tracker, and I'm stumped if I can find the cause. I installed it to get hold of the version number in the peer_id (for our allowed client list), but am getting the error: "bad data from tracker - invalid bencoded value (data after valid prefix)" I had used BTQueue 0.1.0 build 433 previously on the tracker with no problems. I have added a workaround for clients that use a '?' instead of an '&' between the passkey and info_hash, so if that issue is still around in BTQueue it shouldn't affect us (I have no problems with BitTornado, Torrentflux, etc, those that have this issue). Any idea of what could be causing this? I really do want this client to be able to be used with our tracker (it's a great client!) Thankyou :) dodgy

contact me

Would you please help me investigate this problem? Since I don't have access to your private tracker for sure, it would be easier to quickly modify code and then send new version to you immediately. Thanks in advance. Any help are welcome. sugree [at] gmail.com (Google Talk is ok)

fixed it, sorta

I was running into the same problem, I tried your fix that you posted earlier with no change. I tracked it down to the bencode.py file, where I ended up just commenting out the thrown exception in def bdecode(x):, which gets thrown if bdecode doesn't decode everything. It's not elegant, and I'm assuming the last few characters are junk, but it seems to work!

Post new comment

The content of this field is kept private and will not be shown publicly.